Δευτέρα, 5 Μαΐου 2014

ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ

1. Συμπληρώστε τα κενά (…..) προκειμένου τα παρακάτω τμήματα προγράμματος σε ΓΛΩΣΣΑ της στήλης Α να επιλύουν το πρόβλημα της στήλης Β

ΣΤΗΛΗ Α.
ΣΤΗΛΗ Β.
ΔΙΑΒΑΣΕ Α
ΑΝ Α …….  ........ = 0 ΤΟΤΕ
ΓΡΑΨΕ ‘Ο’, Α, ‘ΕΊΝΑΙ …..’
……
……. ‘Ο’, Α, ‘ΕΙΝΑΙ ….’
………

ΕΛΕΓΧΟΣ ΑΝ ΕΝΑΣ ΑΡΙΘΜΟΣ Α ΕΙΝΑΙ ΜΟΝΟΣ ή ΖΥΓΟΣ ΚΑΙ ΕΜΦΑΝΙΣΗ ΤΟΥ ΑΠΟΤΕΛΕΣΜΑΤΟΣ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
         ΔΙΑΒΑΣΕ Ν
…..  Ν….. 5
Σ …….    ……..
ΓΙΑ …… ΑΠΟ ….. ΜΕΧΡΙ  Ν ΜΕ_ΒΗΜΑ …..
Σ  <-- …….  ……..  ………
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘……………..’, …..

Να γραφεί πρόγραμμα που να διαβάζει θετικό ακέραιο αριθμό Ν>5 και να υπολογίζει το άθροισμα των περιττών μεταξύ 1 και Ν.

2. Προσδιορίστε τον τύπο και το όνομα στις παρακάτω μεταβλητές:
ΜΕΤΑΒΛΗΤΗ
ΟΝΟΜΑ
ΤΥΠΟΣ
ΑΡΙΘΜΟΣ ΠΑΙΔΙΩΝ


ΜΙΣΘΟΣ


ΟΝΟΜΑ ΜΑΘΗΤΗ


ΥΠΟΛΟΙΠΟ ΑΚΕΡΑΙΑΣ ΔΙΑΙΡΕΣΗΣ



3. Ποιο πρόβλημα επιλύει ο καθένας από τους παρακάτω αλγόριθμους:
ΑΛΓΟΡΙΘΜΟΣ
ΠΡΟΒΛΗΜΑ
<--0
<--0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
ΔΙΑΒΑΣΕ Α
ΑΝ Α>=0 ΤΟΤΕ
<--P+1
ΑΛΛΙΩΣ
<--N+1
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ Ρ
ΓΡΑΨΕ Ν

Κ <-- 3.14
ΔΙΑΒΑΣΕ Ρ
Ε <-- Κ*Ρ*Ρ
Π <--2*Κ*Ρ
ΓΡΑΨΕ Ε
ΓΡΑΨΕ Κ
ΓΡΑΨΕ Π



4. Να περιγράψετε τον παρακάτω αλγόριθμο με διάγραμμα ροής
....
ΔΙΑΒΑΣΕ Χ
FOUND<--0
Ι<--1
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘Προσπάθεια:’, Ι
ΔΙΑΒΑΣΕ Α
ΑΝ Α=Χ ΤΟΤΕ
ΓΡΑΨΕ ‘ΜΠΡΑΒΟ ΤΟ ΒΡΗΚΕΣ’
FOUND<--1
ΑΛΛΙΩΣ
ΑΝ Α>Χ ΤΟΤΕ
ΓΡΑΨΕ ‘Ο αριθμός που έδωσες είναι ΜΕΓΑΛΥΤΕΡΟΣ’
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘Ο αριθμός που έδωσες είναι ΜΙΚΡΟΤΕΡΟΣ’
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ FOUND=1
....

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου